Back
Maintenance

volt.team Server maintenance

Completed 21 Jan at 09:24pm CET.

volt.team
Completed

The updates have been performed successfully.

Posted 21 Jan at 09:24pm CET.
Started

We’re performing some maintenance tasks which might lead to a short service interruption.

Posted 21 Jan at 09:15pm CET.